• Register
Description

----------------------------------- This is an old version of RA: APB. It is incompatible with the current public versions. Please download the latest available version instead. ----------------------------------- Obsolete client patch. This APB patch requires you to have 1.3.0 or 1.2.0 already installed, and will update you to 1.3.1 version.

Preview
Obsolete - APB 1.3.1 PATCH (for 1.3 / 1.2)
Comments
Scarwing
Scarwing

funny... as soon as i click on APB the browser i looked at 10 minutes ago showed this... i guess i am lucky for an update.

Reply Good karma Bad karma+6 votes
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.