• Register

Super Amazing Wagon Adventure is a 2D action game with a random crazy story! You control a group of three migrating west on a wagon trail. The game consists of short 3-30 second long scenes that are sequenced together in a semi-random way, so you never know what dangers you will face. Battle buffalo, wolves, bandits, bears, giant spiders, aliens, and much more!

Forum Thread
Cannot launch Super Amazing.... (Games : Super Amazing Wagon Adventure : Forum : Support : Cannot launch Super Amazing....) Locked
Thread Options
Aug 20 2013 Anchor

My kid wanted this game. I downloaded and installed the Desura execution enviroment and the game Super... seemed to install, but when I launch it nothing happens. I am running 64 bit Windows 7.

Aug 21 2013 Anchor


Sorry the game's not working on your machine. What I'd recommend trying is downloading and running the standalone EXE installer for the game which you can download from the Desura website here: Indiedb.com You'll need to visit that link in a normal web browser (you can't download the installer from within the Desura program) while logged in with your account. The installer should show up on the right hand side of the page under Downloads and it's listed as "Full EXE Installer." Running this installer should make a start menu shortcut so you can run the game directly without running Desura. This shouldn't normally be necessary but if this should narrow down whether it's an issue launching the game from Desura or just running it in general.

If the game still doesn't work when you run it directly from the start menu please let me know. Also if there are any error messages that appear when you run the game directly please do include that information.


Aug 23 2013 Anchor

Sorry to hijack this topic but I'm having the same problem. I tried the standalone exe but the same thing happens: the game's process shows up in the task manager for a few seconds but then closes without anything else happening.

The strange thing is that the game worked fine when I bought it on the 20th, the only thing I've changed on my laptop is installing a virus definitions update through Windows update so I have no clue what can be causing this.

This has become my favorite historical simulator so hopefully I can get it working again.

Edited by: Coldyron

Aug 24 2013 Anchor

That's very odd if the game was working and then stopped working The game hasn't been updated recently (the last update was months ago) so unfortunately I'm just about as clueless as you as to how the game stopped working. Sorry about that!

A couple of things I'd suggest trying:

(1) Uninstalling and then reinstalling the game using the standalone exe installer.

(2) Deleting your save file which is located under "Documents\SavedGames\WagonAdventure\WagonAdventure\AllPlayers\save.xml". This will erase your unlocked wagons and high scores but could possibly fix the problem if it's being caused by an issue with reading the save file. If you make a copy of this file before you delete it I can also possibly help you fix the file. / get back any unlocks.

(3) Changing your desktop resolution and disabling any secondary monitors. By default the game attempts to start in full screen at your desktop's resolution.

If none of these fix the problem let me know and I'll figure out some other things to try. Sorry that the game isn't working for you, and thanks for your patience.


Aug 24 2013 Anchor

I tried all of those suggestions and did a system restore to before I first installed the game but it still isn't working. I have no clue what could have caused this so I really appreciate the help.

Aug 25 2013 Anchor

I'm sorry it's still not working :( I'd suggest trying these things next:

(1) If the game doesn't start at all sometimes this could be an indication your XNA installation is broken for whatever reason XNA is a game framework made by Microsoft which the game uses. I'd suggest trying to run a different XNA game to try to narrow down whether XNA is working or not. The game Rogue Legacy uses the same version of XNA as my game and has a free demo available here: Indiedb.com

(2) If you check in Window's Event Viewer there might be some more information. You can find it by searching for Event Viewer under programs in Windows 7 or "View event logs" under Settings in Windows 8. In there you'll want to look under Windows Logs > Applications and look for events having to do with Wagon.exe. If there's anything there, if you could email me the details (sparsevector at sparsevector dot com) that could help me figure out what's wrong. You could also paste the information here but there could be some information you don't want to post publicly (e.g. your Windows username or something). When you click on an event there should be an option to copy it as plain text on the right hand side of the screen.

Let me know how this goes. If it turns out to be a problem XNA, the first thing I'd try is uninstalling XNA and then reinstalling from here: Microsoft.com

Edited by: sparsevector

Aug 26 2013 Anchor

I previously bought Rogue Legacy so I launched it and it is also broken. I reinstalled XNA but that didn't fix it.

I'm going to email you the error logs for before and after I reinstalled XNA along with a .NET runtime error that showed up a few seconds earlier, I'd post them here but the formatting gets messed up when I try. I saw the error had something to do with the .NET Framework so I tried the repair tool (http://www.microsoft.com/en-us/download/details.aspx?id=30135) but it didn't help. For what it's worth Rogue Legacy gives the same exact errors as this game both pre- and post-XNA reinstall.

Aug 27 2013 Anchor

Thanks for emailing the error reports! From looking at the errors and since Rogue Legacy is giving the same errors, I think it's pretty safe to assume it's a problem with either your XNA installation or your .NET installation or both. Unfortunately since these kind of issues are outside of the game itself, I'm not much of an expert on them, and I don't have a lot of ideas aside from repairing / reinstalling .NET / XNA, which you've already tried. From searching I found a couple of other things:

(1) On the Rogue Legacy tech support thread I found this thread which talks about a file permissions problem that could cause XNA games to not run Steamcommunity.com The thread describes how a change to the permissions on some .NET related files which could fix this. However, the error reports don't match exactly what I'd expect for this problem (there's nothing related to file IO / permissions in your error), so I'm not sure if this would work. I also haven't tried this fix myself so I'm not 100% sure it's a safe change to make to your computer (changing permissions on system files is in general not a great idea). If you try this I'd definitely back up any important files beforehand just in case.

(2) I found some mentions online that this error could be caused if you are running very low on disk. If that's the case I'd definitely try freeing up some space.

(3) I found a couple of reports that the particular error code you got, which is "ExecutionEngineException" from the .NET runtime error report can be caused by an uncommon bug in .NET itself. However, I think this bug would only happen on rare occasions and not every time you start the program, so I don't think that's the issue.

That's about all I could find. I'll look into it some more, but unfortunately as I mentioned the problem seems to be with the XNA and / or .NET setup in general which is somewhat outside of my expertise. Sorry the game isn't working and thanks again for your patience.


Aug 28 2013 Anchor

None of those worked either... If you find anything else let me know but don't worry too much about it, I've googled the error code but didn't find anything useful (or anything I could really understand) so I'm about ready to give up. I'm beginning to think this is my laptop's way of telling me I'm going to need to replace it soon. I really do appreciate the help though.

By the way, congrats on getting greenlit on Steam!

Aug 29 2013 Anchor

Thank you! And sorry I couldn't figure out how to get it working. Unfortunately .NET is so integrated into the operating system it can be really tricky to get working again when it breaks. I'll let you know if I find out anything more or have a new idea of what to try.

Sep 1 2013 Anchor

I got it working! Completely uninstalling the latest .NET version and reinstalling it did the trick. I'm not sure why I didn't try that earlier but I'm just glad it's working now.

Thanks again for all the help!

Sep 2 2013 Anchor

Awesome! I'm glad you got it working. Just out of curiosity, did you uninstall .NET via Add/Remove programs or did you use some other tool? It might be good to know in case someone else runs into the same problem. Thanks!

Sep 2 2013 Anchor

I uninstalled it through add/remove programs, I think there was an entry for something like .NET 4.5 that I was able to uninstall.

Sep 3 2013 Anchor

Thank you! That's good to know.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.