• Register
Forum Thread
Problems with Doom Builder 2 (Forums : Level Design : Problems with Doom Builder 2) Post Reply
Thread Options
Jan 24 2021 Anchor

I don't know if this is the place to post this, but I don't know where else to. In Doom Builder 2, I'm trying to make a level. I've made a few levels before, but this time there's something with the walls which is really bugging me, and I couldn't find any other threads about. The walls, and the floor to an extent, have this awful lighting gradient on them. I don't know what triggered this, or how to turn it off.

Screenshot Doom 20210124 222637

Jan 25 2021 Anchor

According to manual just point the mouse cursor at a wall and press:

Decrease Brightness CTRL+Scroll-Down

Increase Brightness CTRL+Scroll-Up

..page 79, section 2.4.2 on that manual

Complete direct manual download is here:


Jan 25 2021 Anchor

I understand how normal lighting works, and how to increase/decrease brightness, but the problem carries throughout entire segments, regardless of what I set the brightness to. The problem seems to be expressed in this part of the guide, but it isn't too descript.

GRADIENT BRIGHTNESS will evenly grade and distribute the brightness levels of the Sectors
selected between the first and last Sectors.

When I'm in sectors mode, there are three options in the top right; Make Brightness Gradient, Make Floor Heights Gradient, and Make Ceiling Heights Gradient. I'm assuming the option I'm looking for is Make Brightness Gradient, but whenever I select a sector and click the option, I can't tell if the option is triggered on or off. In the bottom left of my screen, where it tells you what the last action was, it always says "Created gradient brightness over selected sectors." which suggests that it it only ever being triggered on, but never off.

Feb 2 2021 Anchor

Try to disable lighting at all. Watch out for distance view to eliminate that black ground, page 12 of the manual.
My suggestion, reinstall of everything, builder2_setup and corrupted .wad files.

Feb 4 2021 Anchor

I may have found some sort of solution. The issue seems to be with GZDoom in general. I'm not EXACTLY sure what causes it, but graphics settings are the problem (who would have known.) Unfortunately, I'm still not exactly sure which option it is, though it seems be related with my rendering options, and the gradiant only appears when I have Hardware Accelerated on.

Feb 9 2021 Anchor

Maybe DirectX 8.1 alpha blending weakness versus DirectX 11

-Builder need update.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.