• Register
Description

v. 2.1b - compatible with nightly patch and steam version until at least 20th July 2017 (equivalent to build r2349); NOT COMPATIBLE WITH OTHER SUBMODS! MAKE SURE YOU GET THE LATEST VERSION OF TLD!

Preview
TLD Scene Replacement 2.1b
Comments
Sid_The_Kid
Sid_The_Kid

Thank you very much!

Reply Good karma Bad karma+2 votes
In_Vain Author
In_Vain

You're welcome! :)

Reply Good karma+2 votes
Rubertoski
Rubertoski

It doesn't work..I have non-steam 1.172 version..Do I have to wait an update?

Reply Good karma Bad karma+1 vote
In_Vain Author
In_Vain

Can you give me a bit more detail, please? Which nightly patch do you have installed? What exactly doesn't work?

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Tags

TLD Scene Replacement 2.1b has not been tagged yet.