• Register
Description

!!DISCLAIMER!!Please uninstall the previous version before installing this one,thank You! The saves are 100% compatible with the saves from Native Redux 1.3 For full list of changes read more ->

Preview
Native Redux 1.4
Comments
Guilhermemcmxcix
Guilhermemcmxcix

V1.143 do Warband?

Reply Good karma Bad karma+2 votes
SaskyGames Author
SaskyGames

The mod works on version 1.173 of warband

Reply Good karma+3 votes
Guilhermemcmxcix
Guilhermemcmxcix

thank kkkkkkkk sou Brasileiro,
but not a few languages

Reply Good karma Bad karma+2 votes
Guilhermemcmxcix
Guilhermemcmxcix

a pity I only have Version 1.143 I will have to buy a more powerful computer to for a newer version of the warband but thanks a lot for the info so far foce the only mod creator to answer me

Reply Good karma Bad karma+3 votes
SaskyGames Author
SaskyGames

No problem :)

Reply Good karma+2 votes
Guest
Guest

how about 1.174?

Reply Good karma Bad karma0 votes
SaskyGames Author
SaskyGames

Tested and everythng works fine :D

Reply Good karma+1 vote
Guest
Guest

Does it work on v1.163?

Reply Good karma Bad karma0 votes
SaskyGames Author
SaskyGames

I haven't tested it yet on that version,but I have no idea why it wouldn't :)

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.