• Register
Description

The problem with the v1.5 release was missing files from the Expanded Horizons mod by xpo777. This hotfix also removes Fort Clinch, changing it to Augusta, as well as replacing the former Augusta location with  Raleigh, and moving it to North Carolina. This should help fill up the empty space in that area. I have updated the menus.txt to accommodate the mod's new items when viewing the game's total inventory in the cheat menu. You will need to start a new game as well, if you have already started one.

Preview
The American Civil War Mod: Revived! Version 1.5 Hotfix
Comments
Guest
Guest

Sorry sir, this fix still can't solve the problem of RGL, or do I have to use the old version to solve the problem?

Reply Good karma Bad karma+1 vote
King85 Author
King85

Hello, can you explain what exactly you did? You do need to make a clean install of version 1.5 before you apply the hotfix.

Edit: If you are trying to use Expanded Horizons and having problems still, my colleague, Matsuri5, has suggested doing this:

"if I understand correctly, when you install the expanded horizons to the mod's resource folder (NOT warband commonres/resource), you do need to change the module.ini to load_mod_resource on all 4 files under PL and remove the # from the first 4 entries."

Reply Good karma+1 vote
King85 Author
King85

Oops, sorry, I made a small grammar mistake that is important to understand the instructions. He said to, "remove OR # the first 4 entries".

Reply Good karma+1 vote
Guest
Guest

I am a player in Taiwan. I use the most original and pure 1.5 to play the game and still run out of the RGL crash report. I opened it using the English system and installed 1.5hotfix still ca n’t play the game. By the way, can we authorize the opportunity for Chinese players to translate? It can effectively open a communication opportunity for Chinese players. Chinese players also have many excellent mod makers and can also help you with the DEBUG program.

Reply Good karma Bad karma+2 votes
King85 Author
King85

Can you please tell me how you installed the hotfix? Did you try to use Expanded Horizons or did you try the method without it? I just want to make sure you did everything correctly during installation to eliminate that possibility. Maybe I didn't write the instructions very well, perhaps I should fix that for you guys who speak English as a second language.

If you did everything right during installation, and it is instead something wrong with the hotifx, I will need more information about what kind of error you are receiving. That should give me the information about where the problem is originating and I can try to see what is going on.

Oh, and yes, feel free to translate the mod, and if you want to, you can upload the translation here. I'll post it for you on the mod's page if you want, or you can put it up in the forums. Whatever works best for you guys.

Reply Good karma+1 vote
zhenbintoh
zhenbintoh

你好,我来自马来西亚。
你有下载对的版本吗?

Reply Good karma Bad karma+1 vote
The_Hussar
The_Hussar

Everything works fine for me but would you add some menu options for directly visiting the city mayors in towns and also some faction unit trees would be welcome. Also what's the purpose of those 2 forts in the Caribbean? Also can you fix crouching?I enabled it from mudule.ini but once you crouch you can't get up.

Reply Good karma Bad karma+2 votes
Matsuri5
Matsuri5

When u take out ur weapon (or sheath it again?) u should get up

Reply Good karma Bad karma+2 votes
King85 Author
King85

You know how to make the character crouch? Wow, please do share that information! I'd love to work on that, at least for the player to use. It would also be pretty neat if I could figure out how to keep infantry soldiers standing up and and make skirmishers and mounted infantry kneel.

The extra menu options should be possible, if it requires the module system, though, it will have to wait.

Just ignore those places in the carribean, they are something left over the dead mod and I have to figure out how to remove them.

Reply Good karma+1 vote
TheMightyRotz
TheMightyRotz

Crouching would be an awesome addition!

Reply Good karma Bad karma+1 vote
Matsuri5
Matsuri5

an option to crouch could be enabled thru module.ini;
scroll down bottom of file and set
can_crouch = 0 to can_crouch = 1

not sure if/how a key can be assigned tho

Reply Good karma Bad karma+1 vote
Officer_Otto
Officer_Otto

You should check this

Forums.taleworlds.com

Reply Good karma Bad karma+1 vote
hit1945ler
hit1945ler

SRY,but I still can't understand how to change the module.ini.

Reply Good karma Bad karma+2 votes
hit1945ler
hit1945ler

I use Expanded Horizons then can't play the game.

Reply Good karma Bad karma+1 vote
Matsuri5
Matsuri5

if u follow the expanded horizons readme they go into root warband and i guess then the module.ini should work, but u could remove the first 4 entries of op_terrain_borders and keep the 4 under the PL section; or u can paste the brfs into resource file of the mod; then u keep only the last 4 entries but refer them to the mod ; load_mod_resource =

Reply Good karma Bad karma+2 votes
Guest
Guest

Yes, I did not install any mod clean game files into the 1.5hotfix file after I put the 1.5 files into Modules. The game still showed a crash report of RGL. I repeatedly installed the same result several times, but unexpectedly The problem is that I can successfully open the game on another computer. I also asked my friends to think about how to solve this problem. Thank you for bringing such an excellent mod.

Reply Good karma Bad karma+1 vote
King85 Author
King85

Hmm, this is so weird. I have a similar problem, where the mod works on my machine, but seems to be giving others issues. That's why this is such a troublesome issue, it is difficult for me to be certain that the changes I make will work for everyone. Some say they have no issues, others say they do, so it's all quite confusing haha.

Please try to install the mod without expanded horizons, at least to see if it works at all. You don't really need it to play, it's just something extra. The method without expanded horizons is most likely more stable. If that works, then I know for sure that the expanded horizons method is the problem and needs to be looked at. I think Matsuri5 might have the answer, in his response to hit1945ler, above your comment here, so that would be a good next step to test a new solution.

Reply Good karma+1 vote
hit1945ler
hit1945ler

I put the 1.5 files into Modules,then paste Expanded Horizons from 1.5Hotfix,then paste menu.txt and parties.txt.I still can't play this game.

Reply Good karma Bad karma+2 votes
King85 Author
King85

Please try the method without expanded horizons, at least to see if it works at all. Expanded horizons is not mandatory to play the mod, it is just something extra if you want it.

Also, Matsuri5 may have the solution in his response to your previous comment, you can give that a try as well to see if it solves the problem for you.

Reply Good karma+1 vote
Argeomer
Argeomer

What is the Expanded horizons mod?

Reply Good karma Bad karma+2 votes
King85 Author
King85

It is a small addon that, from what I understand, makes the backgrounds of scenes look more vast and realistic.

Reply Good karma+2 votes
Argeomer
Argeomer

ok nice. Thank you for the information

Reply Good karma Bad karma+2 votes
TheWizard01
TheWizard01

looking back at the history of expanded horizons, the mods been having this kind of issues for a decade with not being able to open CommonRes/op_terrain_borders_textures.brf

Reply Good karma Bad karma+2 votes
King85 Author
King85

Oh wow, thank you for letting me know, that's good information. Seems like we found our culprit!

Reply Good karma+1 vote
Matsuri5
Matsuri5

well, i don't think that is the issue, u have to refer them right in the module.ini, and follow the readme.
We are working on custom borders that will be part of the mod,
these entries were a leftover for early trials.
I've added expanded horizons long ago, and to several mods myself and never once had an issue.
they don't overwrite anything in commonres, u just need to refer to them correctly.

Reply Good karma Bad karma+2 votes
Guest
Guest

What do you do with the 'bugle calls' folder? Put it in sounds?

Reply Good karma Bad karma+1 vote
King85 Author
King85

You can just put the folder on the desktop, or wherever is convenient for you. I'm not sure if the VoiceBot program will play the bugle calls for other people without the sound files, so I included the sound files just in case.

In the case the bugle calls don't play without the sound files extracted to your destination, you can then extract them at that point and edit the commands inside the VoiceBot program to make sure they are getting the bugle calls from their correct location.

Reply Good karma+1 vote
Guest
Guest

Hello, I found a very special problem. My computer cannot open the game in English, but I can open the game in Chinese and confirm that the game is not a problem at all. This is something that makes me very curious. This is what makes me and my friends completely imagine. Less than

Reply Good karma Bad karma+1 vote
King85 Author
King85

What a bizarre situation this is lol, has my mod become self aware, or what?

*tries to start mod*

The computer: Youtube.com

Reply Good karma+1 vote
Matsuri5
Matsuri5

the answer to any problem:
42 ... or come back in 10 million years

Reply Good karma Bad karma+2 votes
TheWizard01
TheWizard01

Matsuri07 I looked up the mod with every issue I could think of and everything that pops up is the mod being horrible and the issues causing overlapping mods to lap core files that break the game. The issues literally date over 10 years and still exist

Reply Good karma Bad karma+1 vote
TheWizard01
TheWizard01

I was finally able to force the mod to run the biggest issue with that is Error unable to find interior mesh ch_meet_plain_a and get_object failed for mesh: map_tree_a through map_tree_q

Reply Good karma Bad karma+1 vote
Guest
Guest

Hey i have done a clean install and done the hot fix with out the expanded horizons. but every time i try to load the game it crashes on loading the ini file. please help!

Reply Good karma Bad karma+1 vote
King85 Author
King85

Hello, can you tell me what kind of error you are getting when the mod crashes?

Reply Good karma+1 vote
theggamer27
theggamer27

whats Expanded horizon?? its a fix thing or it add something?

Reply Good karma Bad karma+1 vote
King85 Author
King85

It is a small addon that, from what I understand, makes the backgrounds of scenes look more vast and realistic. You don't need it to play the mod. It was accidentally included, and it ended up causing CTD's, so we included a fix to either use Expanded Horizons, if you actually want it, or how to use the mod without it.

Reply Good karma+1 vote
Guest
Guest

Cant extract Im using WinRAR

Reply Good karma Bad karma+1 vote
King85 Author
King85

What kind of error are you getting?

Reply Good karma+1 vote
Guest
Guest

Nvm i figured It out you have to use 7 Zip

Reply Good karma Bad karma+1 vote
Guest
Guest

I follow all the steps and didn't work so next time don't make mod <3 :D

Reply Good karma Bad karma-1 votes
King85 Author
King85

Sorry, if you don't tell me where you are encountering problems, there is nothing I can do to help you. Everyone who has had problems has been able to politely ask for help and have been successful in getting the mod to work.

I will keep making this mod, in spite of its faults, thank you very much. If you think you can do a better job, you can go right ahead and do so. <3 :D

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.