• Register
Description

We are proud to present you the second version of the upcoming first person tower defense game: Project FPTD. This release contains richer experience, smoother gameplay and much more content than the previous one. Shader Model 3 graphics card and administrator privileges are required.

Preview
Project FPTD v0.2
Comments
indorile Author
indorile

Controls:
Movement - WASD
Shooting - Left Mouse Button
Tower Control - E
To buy from shop - Navigate the list with mouse and press E on the red buy button
To build from console - Navigate the list with mouse and press the build/upgrade button. To select the build panel from third person perspective, navigate with mouse and press E.

Reply Good karma+1 vote
valatmir
valatmir

I wait for this ;)
Best game with this engine!!

Reply Good karma Bad karma+1 vote
valatmir
valatmir

Can i buy new Weapons?

Reply Good karma Bad karma+1 vote
valatmir
valatmir

Map 2 (Snow) is buggy

Reply Good karma Bad karma+1 vote
Sivonja
Sivonja

For now only stun gun is what u can buy .....and snow map is W.I.P

Reply Good karma Bad karma+1 vote
valatmir
valatmir

The snow map is pretty^^!
And where i buy new weapons?

Reply Good karma Bad karma+1 vote
ThruggHarrog
ThruggHarrog

There are shops on both maps, floating two panels. On left one there is a list of stuff you can buy, on the right one, there is description, price, etc. Below it is a buy button.

Reply Good karma Bad karma+1 vote
hr0nic
hr0nic

great game, very playable and interesting, I play it on an average configuration, and works very well. I am pleased to see how this project progresses:) I wish you all the best:)

Reply Good karma Bad karma+1 vote
indorile Author
indorile

Thank you very much, we're glad you like it :)

Reply Good karma+1 vote
GTG3000
GTG3000

Um... couldn't get it working on win7x64
I HAVE physX installed, but the game says I don't.

Reply Good karma Bad karma+1 vote
indorile Author
indorile

You'll need to uninstall it and then install it from Project FPTD/Support folder. When I installed Dark Void it messed up my PhysX by installing older one. Needed version is 2.7.3 and setup from Support folders contains all versions up to 2.8.1

Reply Good karma+1 vote
GTG3000
GTG3000

heh, I had Dark void installed, too.
How convenient.

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.