• Register
Description

This is the newest version of Napoleonic Wars++, this is speciffically the installer version. also before launching the mod please disable load textures on demand on the warband launcher as about a quarter of the people who play report a error that the rest of us don't receive and disabling that seems to have fixed it for them.

Preview
Napoleonic Wars++ 2.0 Installer
Comments
drterrorist0
drterrorist0

what's the difference between installer , module & patch ?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.