• Register
Description

Version 1.1 release. Now with 99% greater compatibility with other mods! No more PowerShell script, CamelArmor is now fully module-based. Just extract the zip file into your Bannerlord Modules folder and enable the mod on the Bannerlord launcher - and that's it. You can still fine-tune settings in the config.xml file, if you so desire.

Preview
Camel Armor Mod (Version 1.1)
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Tags

Camel Armor Mod (Version 1.1) has not been tagged yet.