• Register
Add file The American Civil War Mod: Revived! Full Release Version 1.5

This full version has been archived by the uploader because it is out of date and no longer supported. We recommend you browse the file list for the latest full version.

Location
Files
Filename
ACWMR_v1.5.rar
Category
Full Version
Uploader
King85
Added
Size
437.94mb (459,216,286 bytes)
Downloads
5,174 (1 today)
MD5 Hash
ac1dac72802093b67d5f4d6815e9f5cd
Embed Button
Embed Widget
Description

The American Civil War Mod: Revived version 1.5 is ready for a full public release! This new version includes many great new additions, such as new weapons, new uniforms, new units, new sounds, new animations, voice commands, and much much more! Continue reading below for a full changelog, and refer to the latest article for in depth dive into some of the great new additions to the mod. A great deal of thanks is due to Matsuri5, Helm8000, Эльдар, Kawooz_Mirza, pizzaman6, UwU_XD, the Blood and Iron team, Tasmit, and all the help from members of the community reporting bugs, giving suggestions, and providing support for the mod in every way; none of this would be possible without you all and the hard work you put in to help with this mod's development.

Preview
The American Civil War Mod: Revived! Full Release Version 1.5
Comments  (0 - 50 of 68)
Krisconpro
Krisconpro

Very cool Kanye!

Reply Good karma Bad karma+4 votes
Master_Rawl
Master_Rawl

The mod is crashing for me on launch with an RGL error. Thanks for working on this. It has potential.

Here's the error.
I.imgur.com

Reply Good karma Bad karma+5 votes
Guest
Guest

Same here

Reply Good karma Bad karma+1 vote
King85 Author
King85

Hello, I believe I have found the solution to this issue. Please read the installation instructions again, I have updated them with the solution for this problem on step 3.

Reply Good karma+1 vote
Fallouthobo
Fallouthobo

Indeed looks good but I'm getting the same crash as well.

Reply Good karma Bad karma+3 votes
King85 Author
King85

I'm going to reply to everyone personally so far who had problems, I want to make sure you all know the issue has been successfully resolved and you can find the solution in the updated installation instructions on step 3. Thank you all so much for you support and your patience!

Reply Good karma+1 vote
SockStealerAK
SockStealerAK

I'm getting the same Error as Master Rawl on launch. Update looks great just unable to launch.

Reply Good karma Bad karma+3 votes
King85 Author
King85

The issue has been successfully resolved and you can find the solution in the updated installation instructions on step 3. Thank you so much for your support and your patience! I'm sorry the mod had this problem on release, I should have tested it with other people and not just on my own PC. As always, this is still a learning process for me, and I hope everyone can understand it was an honest mistake and that quality checks and testing will be more thorough next time around to hopefully prevent another situation like this.

Reply Good karma+1 vote
SockStealerAK
SockStealerAK

Thank you for letting me know! Don't sweat it either you do good work and I know you put your own time in to make this mod. So I appreciate it and thank you for working on this gem of a mod. Hope it goes far.

Reply Good karma Bad karma+2 votes
King85 Author
King85

Thank you so much for understanding, it breaks my heart that the mod is not working for so many people. If the new solution I posted in the instructions and on the article actually work for you, please let me know so I can have more confidence posting a hotfix. I really want to avoid posting something that is supposed to fix the mod, only to have it not work either. The more people that confirm the new instructions indeed work, the more likely it is that the solution will work for everyone. Thank you again for supporting the mod and sticking by it, I am here for you guys until this job gets done.

Reply Good karma+1 vote
SockStealerAK
SockStealerAK

I tried the mod this morning and the fix indeed works. I’m loving this update a lot including the updates officers uniforms. The screams are also a great addition and adds to the immersive experience in this mod. Not a whole lot of people include that in their **** and I can say it goes a long way. Keep up the great work! You’re kicking ***.

Reply Good karma Bad karma+2 votes
King85 Author
King85

Oh what wonderful news! I am so very glad to read this, and I am happy that you are enjoying the mod. It brings a big smile to my face to see it finally up and running. I hope you have fun with it for a long time, and I look forward to continuing to give you guys further improvements. Next time, I will be asking for play testers to help avoid another troubled release.

Good luck on the battlefield! :)

Reply Good karma+1 vote
Joaossc
Joaossc

This mod should be great but sadly i'm having the same error as Master_Rawl

Reply Good karma Bad karma+1 vote
King85 Author
King85

The issue has been successfully resolved and you can find the solution in the updated installation instructions on step 3. Thank you so much for your support and your patience! Sorry that this problem came with the release, I will be testing the mod with more people next time to hopefully avoid another foul up.

Reply Good karma+1 vote
Helm8000
Helm8000

HEY ALL, unofficial fix to launch the mod for now, Open your "module.ini" file found in the mod folder, find the lines that say, these appear two times in the file so just Ctrl F to find them if you can't

load_resource = op_terrain_borders_textures
load_resource = op_terrain_borders_materials
load_resource = op_terrain_borders
load_resource = op_terrain_borders_b

Put a # in front of these lines (it makes the game ignore them) as they arent in the mod files.

So you should have this for the two times these appear in the module.ini
#load_resource = op_terrain_borders_textures
#load_resource = op_terrain_borders_materials
#load_resource = op_terrain_borders
#load_resource = op_terrain_borders_b

The mod should work afterwords.

Reply Good karma Bad karma+3 votes
AsherNitin
AsherNitin

Your tip worked. Managed to progress to the character creation page, then mod crashed because it couldn't load the dry grass textures. I think this mod was designed to work with an older version of Warband, 1.156 maybe.

Reply Good karma Bad karma+1 vote
King85 Author
King85

Hi, I'm sorry you're still having trouble with the mod. Please open module.ini and add a # under the entries in the PL section, that might do the same as what Helm8000 suggested and stop those entries from loading as well.

I hate to disappoint you all, I'm sorry the mod is having problems. I wish I knew what was wrong, this is really perplexing to me.

Edit: after putting a # in front of the PL entries (or deleting the section entirely), please remove the # from map_tree_meshes, particle_meshes, tree_meshes, xtree_meshes, grass_meshes, and plant_meshes, which can be found at the beginning of the load_resource list.

Reply Good karma+2 votes
King85 Author
King85

I'm glad to report this issue has been successfully resolved and you can find the solution in the updated installation instructions on step 3. Thank you so much for your support and your patience! I apologize for the bit of trouble on release, next time I will be testing the mod with other people and not just on my own computer. That was my mistake and I take responsibility for that.

Reply Good karma+1 vote
AsherNitin
AsherNitin

Thank you very much. I have always wanted an ACW mod, being a big fan of Bernard Cornwell's Starbuck Chronicles. Thank you for your commitment and lack of eccentricity (often seen among mod devs) thus far.

Reply Good karma Bad karma+2 votes
King85 Author
King85

Hello, just want to let you know as soon as possible, loulou76100 has had success getting the mod to work by replacing the module.ini with a copy from the last version of the mod, and adding the two new entries for weapons .brfs at the bottom. If you have success as well, please let me know so I can make an official confirmation of this solution actually working, and then I will probably just upload a hotifx with a new module.ini

Reply Good karma+1 vote
AsherNitin
AsherNitin

As of this moment, new version is non-functional/unplayable. Either vital instructions (for mod requirements) have been omitted or simply the mod has been released un-tested. First fails to load (terrain borders resources problem), fixed by another comment earlier in this section, then CTD because textures problem. Best not to download until a less enthusiastic, more careful version/patch of the mod is released. IIRC, the second problem was a dry grass texture, which is a Polished Landscapes brf. On checking the module.ini there is an separately labelled section for PL resources. It is possible the creator forgot to integrate PL into this version. Alternately, plcing a # in front of the second instance of load_grass_textures and load_grass_textures_b might do the job (the first instances were already #-ed).

Reply Good karma Bad karma+1 vote
King85 Author
King85

Hey there, you might be right about the PL section in module.ini, please try to add a # in front of all the entries under that section, and let me know if it works for you or not.

What's strange is the mod works on my computer with no problem, even though I have done nothing like that myself. I have checked it again several times and there is nothing wrong on my end; the mod starts up, goes through character creation, I can move on the map, fight, everything. It's all fine from what I can see, so I am really confused right now.

Reply Good karma+1 vote
King85 Author
King85

Hello AsherNitin, I'm happy to report that the issue has been successfully resolved and you can find the solution in the updated installation instructions on step 3. Thank you so much for you support and your patience! Sorry for the trouble, I had no idea this was a problem until everyone told me what was going on. As always, the feedback and the help from the community is invaluable and I hold you all in the highest regards. Have a great day, enjoy the mod!

Reply Good karma+1 vote
AsherNitin
AsherNitin

Re-pasting my comment from another conversation above: Much obliged, King85. I have always wanted an ACW mod, being a big fan of Bernard Cornwell's Starbuck Chronicles. Thank you for your commitment and lack of eccentricity (often seen among mod devs) thus far. I am an amateur texturer for one mod (Deeds of Arms and Chivalry) with a small group of veteran modders so I understand the problems with solo testing. Will follow step 3, thankQ. However, may I suggest you release a patch (just the tweaked .ini file?). Will save hassle for future downloaders (?).

Reply Good karma Bad karma+2 votes
King85 Author
King85

Thank you for the suggestion, that's actually a good idea, just to release the module.ini as a patch; I am holding off for now, though, because loulou76100 said below that they were still having problems, despite making the changes I said would fix the problem, so now I am uncertain of what is going on. Once this is sorted out for certain, then I will be more comfortable releasing a little hotfix patch. The last thing I want is to release a patch that is supposed to fix the mod, and then that doesn't work either.

Reply Good karma+1 vote
AsherNitin
AsherNitin

I can confirm, it still does not work after implementing your step3. Appears to be a textures problem. I'm thinking this might be on my side. I have PL installed into my main M&B data folder. Not sure.

Reply Good karma Bad karma+2 votes
King85 Author
King85

Hello thank you for letting me know, this is very troubling. The last thing I can suggest is to replace the module.ini with a copy of the one from the last version of the mod, and then add the entries, "load_mod_resource = acwr_firearms", and "load_mod_resource = rs_weapons", below the entry, "load_mod_resource = new_horses". This is what I would consider the nuclear option, and if using the module.ini from the previous version still doesn't work, with the only changes being the new .brfs for the weapons, then something else has gone very wrong. At that point I will have to scrap the module.ini entirely, start with a new copy from native, and make the same changes that were stable in the previous versions, and add the new .brfs again.

Reply Good karma+1 vote
King85 Author
King85

Hello everyone! Terribly sorry that you are all having trouble with the mod, this is very troubling for me. I did in fact test the mod before release, and everything worked perfectly fine, I never experienced any crashes like what everyone has described. Matsuri5 had recommended I use polished landscapes a while ago, when we were first starting to work together, and I ended up removing them because I found the textures to be too bright. That removal was, I believed, complete and successful, considering I have been playing and testing the mod without issue this whole time since then. So why now the mod crashes after I uploaded the file here is a mystery to me. I have done nothing different, and I even tested the mod again just now, with the same files I uploaded, and it worked perfectly fine. I am just sitting here scratching my head at this point, I don't know what is causing these crashes on other people's machine's but not on my own.

Reply Good karma+1 vote
King85 Author
King85

I may have found what the problem is, after comparing the module.ini with a native copy. The "PL" entry at the bottom of the list, along with all of it's associated resources, can be deleted, and at the beginning of the load_resources list, you will see some of them have a # in front (map_tree_meshes, particle_meshes, tree_meshes, xtree_meshes, grass_meshes, plant_meshes). Please remove the # from in front of those entries and the mod will load those resources rather than the missing PL resources.

Reply Good karma+1 vote
The_Hussar
The_Hussar

I did what was recommended but whenever I encounter a party I get an RGL error "Unable to find interior mesh ch_meet_plain_a"

I also crash when I try to enter the trapper's village in the north

Reply Good karma Bad karma+1 vote
King85 Author
King85

Oh, don't go to the trapper's village, that place is a bunch of nonsense and I don't know how to get rid of it yet.

Can you tell me what exactly you did? Maybe it's possible you didn't remove one of the #'s from an entry in the module.ini that has to do with that? I'm really sorry this is happening, I don't know what on Earth is going on, or how it is possible that the mod works for me without issue but is broken for everyone else. It makes absolutely no sense to me. It's very frustrating and disappointing and I want nothing more than to resolve this issue.

Edit: I looked in the .brf for what you reported the game said was missing, and I actually found it. It's there, but the question now is why is it not loading for you, and I assume other players. I hope everyone can understand that there was no way I could see this coming, I had tested the mod multiple times before I released it, so what is going on right now is something I had no way of knowing existed.

Reply Good karma+1 vote
King85 Author
King85

Oh wait, I think I found the problem, I forgot to mention some of the entries that needed to have their # removed in my previous reply! Make sure you look for all of these, this is the correct list: map_tree_meshes, particle_meshes, tree_meshes, xtree_meshes, grass_meshes, plant_meshes, xtree_meshes_b, xtree_meshes_c, grass_meshes_b, tree_e_meshes, and particles_2

I think now it will work, that explains why "interior mesh ch_meet_plain_a" was not loading; that file is found under particles_2, which I mistakenly left out of the list in my previous reply. There were also a few others in there I forgot to mention, so with this new list I have provided, that should be all of the entries that were deactivated for the early experiments with polished landscapes.

Reply Good karma+1 vote
The_Hussar
The_Hussar

Yes, it does work. Thank you!

Reply Good karma Bad karma+2 votes
King85 Author
King85

Absolutely fantastic! This is great news, what a relief :D

Reply Good karma+1 vote
TheWizard01
TheWizard01

Can you just update the mod so the patch contains these fixes for us who are unable to fix it ourselves

Reply Good karma Bad karma+1 vote
King85 Author
King85

Well, I can of course try to re-upload the mod with the changes to the module.ini, but if those changes aren't working for you, then there must be something else wrong that I don't know about yet. The_Hussar was successful in getting the mod to work with my instructions, so please make sure you have done the same yourself. There shouldn't be any reason it's giving you RGL errors, unless there are still deactivated entries in your module.ini. That is what those errors mean, the game is trying to load resources that aren't there and the only explanation for that is the changes that were made when I was using polished landscapes. As long as those changes are reversed, the mod should work.

Reply Good karma+1 vote
King85 Author
King85

This is for anybody reading this particular comment, please disregard the instructions I gave about deleting entries and removing #. This in fact does not work. A new solution that seems to have more success has been added to the download's installation instructions and underneath the notice on the article.

Reply Good karma+1 vote
loulou76100
loulou76100

So I've applied the fix of step 3 , and yet the same crash still happens. I've uploaded my module.ini file here, I don't really know what I've done wrong...

We.tl

Reply Good karma Bad karma+1 vote
King85 Author
King85

I've looked at your module.ini and I believe here is your problem: "#load_resource = terrain_borders", you need to delete the #.

Reply Good karma+1 vote
loulou76100
loulou76100

still crashes unfortunately, same error message

Reply Good karma Bad karma+1 vote
King85 Author
King85

Oh no, I'm so sorry, jeez what a headache this is. You know what, if you have a copy of the last version of the mod, just replace the module.ini with the old one, and add these entries underneath load_mod_resource = new_horses:

load_mod_resource = acwr_firearms
load_mod_resource = rs_weapons

If you don't have the old version, you can still download it again. I didn't make any other changes to the module.ini since the last release, so if nothing else is working, this nuclear option must do it, otherwise something more serious is going on, and I might have to scrap the whole module.ini entirely, make a new copy from native and redo the changes I made that I know for a fact work without issue, since they were a part of the previous version that was stable.

I really can't believe the mod isn't working, I am just in awe how it is even possible that it works without any problems for me, but it is not working for everyone else. How frustrating. Anyway, please let me know if that works, clearly anything I do on my end is not going to tell me if the changes I make work or not.

Reply Good karma+1 vote
loulou76100
loulou76100

I will try that
No worries though, I really appreciate the help you are willing to give to players, thank you very much!

Reply Good karma Bad karma+2 votes
King85 Author
King85

You're welcome, I'm more than happy to help and I wish very much to see my mod working so everyone can enjoy it and have fun. It breaks my heart that something went wrong on release, I am going to try very hard to fix this.

Reply Good karma+2 votes
loulou76100
loulou76100

Alright, your solution seems to have worked! thanks, King!

Reply Good karma Bad karma+2 votes
King85 Author
King85

Praise the Lord and pass the ammunition! What wonderful news! Now let's see if others have the same success, and then I will either reupload the mod or just post a small hotfix with the new module.ini. Thanks so much for your help, I really appreciate it! :D

Reply Good karma+2 votes
loulou76100
loulou76100

accidental double post, sorry about that

Reply Good karma Bad karma+1 vote
King85 Author
King85

No problem.

Reply Good karma+1 vote
TheWizard01
TheWizard01

How can I even access the module.ini file from notepad

Reply Good karma Bad karma+1 vote
King85 Author
King85

You can open it with notepad++. It will open like a normal text file.

Reply Good karma+1 vote
TheWizard01
TheWizard01

I need steps for it though on how to access the module.ini fuile

Reply Good karma Bad karma+1 vote
King85 Author
King85

Ohh, it is inside the module folder, here: C:\Program Files (x86)\Steam\steamapps\common\MountBlade Warband\Modules\The American Civil War Mod Revived v1.5

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

File
Browse
Files
New
Add file
Share
Related Games
Mount & Blade: Warband
Mount & Blade: Warband Role Playing